Badge showing 0% coverage

My codecov badge is showing 0% for my repo, which until recently was above 95% (the main page seems to match the higher coverage: https://codecov.io/github/bwetherfield/PitchSpellingModel)
https://codecov.io/gh/bwetherfield/PitchSpellingModel/branch/latest/graph/badge.svg

Relatedly, my travis builds fail to upload codecov data: https://travis-ci.com/bwetherfield/PitchSpellingModel/jobs/273048997 , but strangely my codecov dashboard does seem to update.

Source repository: https://github.com/bwetherfield/PitchSpellingModel

Does anyone have insights on this issue? Thanks!

Hi @bwetherfield

It looks like we have a record for b5dcfe3d41ad73c6a6608eb19b75b6067253d0e6, but it didn’t upload in time, so it’s in an error state. Do you know the rough size of the report? Sometimes a large report can cause a failure to upload.

Can you try uploading the report again and let me know if that changes anything?

Thanks for your help, @drazisil!

I think you are most probably right that the upload is too large.

Excerpt from the report generation. Total comes to over 700MB over 13 files, with the larger file over 300MB (before gzipping).

==> Reading reports
+ ./Algebra.framework.coverage.txt bytes=16260
+ ./Pitch.framework.coverage.txt bytes=119654
+ ./DataStructures.framework.coverage.txt bytes=302323
+ ./SpellingNetworksTests.xctest.coverage.txt bytes=84240
+ ./Algorithms.framework.coverage.txt bytes=14935
+ ./SpelledPitch.framework.coverage.txt bytes=81229
+ ./SpellingNetworks.framework.coverage.txt bytes=42489
+ ./Encodings.framework.coverage.txt bytes=13771
+ ./NetworkStructures.framework.coverage.txt bytes=42618
+ ./NetworkStructuresTests.xctest.coverage.txt bytes=6509
+ ./Destructure.framework.coverage.txt bytes=671
+ ./EncodingsTests.xctest.coverage.txt bytes=7975
+ ./Math.framework.coverage.txt bytes=43336

I don’t think I need coverage for all these frameworks. Do you know anything about excluding them using a configuration setting?

Yes, if you use the -f flag of the bash uploader you can tell it which files to upload, instead of it grabbing everything that says coverage :wink:

Hi @drazisil,

Thanks for this! I haven’t had any luck with the -f flag. I’ve been trying various variations of './NetworkStructures.framework.coverage.txt' with * etc. as the file to match, but this does not seem to work.

I had slightly more luck with the -J flag, e.g. -J 'NetworkStructures', but I cannot get it to work with multiple targets. I need three - paths corresponding to SpellingNetworks, NetworkStructures and EncodingsTests respectively.

Do you know where the files live? Perhaps that could help with the targeting of the -f flag…

I don’t, I’m afraid. Perhaps a search of the directories prior to uploading would help?

Here is the section of the uploader that is locating those reports, maybe it will help: