Some files of specific flag are not tracked

Description

I my project, vue3-ssr and plugin-bem flags’ files are not tracked by codecov.

Commit SHAs

b322f68961fa4bf789b53f295960d5a312b27cf2

Repository

CI/CD or Build URL

Uploader

Bash uploader

Codecov Output

Sorry for the output is too long, I need to put the link here.

Expected Results

packages/vue3-ssr
packages/plugin-bem
should be included in the overview page’s chart.

Actual Results

packages/vue3-ssr
packages/plugin-bem
are not included in the overview page’s chart.

Additional Information

Link to the sunburst graph:

Any additional information, configuration or data that might be necessary to reproduce the issue.

@07akioni, I think you’ll want to add -k packages/vue3-ssr etc as applicable to the 3 Codecov bash calls.

Update: I’ve tried the advice and it doesn’t work.

@tom

PR Link

CI Report Link
https://app.codecov.io/gh/07akioni/css-render/compare/45

What’s more I find if I change the uploader. Flag of vue3-ssr and plugin-bem will vanish. See

and

https://app.codecov.io/gh/07akioni/css-render/compare/47


I investigate the generated lcov.info file in css-render subpackage, plugin-bem subpackage and vue3-ssr subpackage and find there aren’t many differences in file’s path pattern.

packages/css-render/coverage/lcov/lcov.info

TN:
SF:src/CssRender.ts
FN:14,CssRender
FN:17,(anonymous_3)
FN:19,(anonymous_4)
...

packages/vue3-ssr/coverage/lcov.info

TN:
SF:src/index.ts
FN:10,createStyleString
FN:14,ssrAdapter
FN:23,(anonymous_2)
FN:29,(anonymous_3)
...

Thanks! I’ll have a try. By the way, the link in

of -k PREFIX is outdated.

It is linked to a github 404 page.

@07akioni, I’m making a fix to the bash uploader, but I want to make sure it’s working for your situation. I’ve started a PR here, but I would love if you could do

bash <(curl -s https://raw.githubusercontent.com/codecov/codecov-bash/7877012ffd85dfb7968f91b5992edd627483dfe0/codecov) -f packages/plugin-bem/coverage/lcov.info -F plugin-bem -i packages/plugin-bem

to use the -i argument. Let me know if this works and I’ll get it merged.

@tom Great job. Now I think it works as my expectation.

Hi @07akioni, ok I merged in the fix. You can resume using https://codecov.io/bash but with the new -i argument.