Private -> public repo not working

I have a similar situation as in this (now closed) support request:

Specifically, I have a repo that originally was private but now is public:

The codecov for it is 100% but the badge is showing “unknown” and under codecov settings it is showing the message “Repository is activated and using one private repo credit.”
So clearly codecov still thinks my repo is private even though it has been public for days.
I tried removing it from codecov and adding it but it seems it was not really “removed” but rather “archived” so the restored version still has the same issue.
I suspect that only codecov can fix this but if anyone has a work around I’d appreciate it!

Hi @JeffFessler

I’ve confirmed we still have this set as private. I’ve passed your request along to someone who can fix this for you :slight_smile:

Thanks for the status update. I would guess that the pattern of starting with a private repo for initial development and then making it public when it is ready is fairly common, so if there are any “best practices” we should use to avoid this issue in the future please let us know! Thanks!
Other than this small issue, codecov is fantastic!

Ok updated! I haven’t seen this issue before but my guess is that the “private” setting was just cached incorrectly in our DB. If we see it popping up again will look for a more foundational solution.

Happy testing!

Jerrod

@jerrod Got the same issue with my repo https://codecov.io/gl/m03geek/node-object-hash.

I’ve tried to delete repo and data and add it again, but it doesn’t help.

Hey @SkeLLLa --> I’ve reset the status of this repo to public for you. Let me know if that worked!

@jerrod, thanks. Now it works well.