Not showing as GiHub checks only as a PR comment

according to this doc, report should show up as a GitHub checks. But I only see them still as a comment.

note: github project is on a private repository

my configuration

codecov:
  notify:
    require_ci_to_pass: no

coverage:
  round: down
  range: '45...95'
  status:
    project:
      default:
        target: 85%
        if_ci_failed: error
    patch:
      default:
        target: 50%
        if_ci_failed: error
    changes: yes

Hi @yul, can you please provide a SHA?

Hi, @tom for some reason, i tried it on Friday but it was not working. I checked again today and it’s already show up as a Github Status :+1:

I do have some feedback. If I disable the github comment:
with this yaml

comment: false

It seems that the one on the Github status is also disabled (not showing graph, file and the details)

what’s ideal for me is that I can stop it to post as a github comment but instead still showing as a Github Status.
Plus i can control the output of Github Status separately from comment (example, disabling the graph)

1 Like

It seems that the one on the Github status is also disabled (not showing graph, file and the details)

I don’t think I quite understand what you mean here. If you want the status to show up, the YAML just needs to be valid. Let me know if I’m misunderstanding.

What i mean is that the comment configuration, configure both “github comment” & “github check” at the same time. You can’t disable it from posting the result as a github comment but still showing the result in the “github checks” tab.

Ideal situation would be that we can control it separately. (eg: disabling posting as a github comment but still have the result (graph, files affected, and coverage information) in the github check tab

Hi @yul, sorry for the wait here. I’ve brought this back to the product team to see if this is something that we can implement. I’ll update here as necessary.