HTTP 400 while uploading to s3 with python codecov from Travis

A travis run that worked yesterday morning is now getting a HTTP 400 while uploading using python codecov 2.0.22.

note: links were broken up due to limit of 4 links in posts by new users

I have two fairly old public projects which I’ve tried hooking up to codecov in the past 48 hours. Both are using codecov 2.0.22 from the output of pytest-cov. The first originally succeeded, but when I moved onto the second it has never passed, and the first gets the same issue when rerunning the Travis job that previously passed.

First project which used to pass:

Second project that always failed:

Additional Information

This may coincide with the scheduled maintenance that occurred yesterday.

I installed the codecov app in GhtHub Marketplace between the two changes, so I also tried uninstalling that but it still fails.

travis-ci.org use to be for free/public projects, and travis-ci.com for paid/private projects, but a few years ago they started migrating everything towards the latter. It seems python-jsonstore wasn’t migrated to the latter infrastructure - I don’t know if that would have any impact. [src].

Codecov Output

$ codecov
      _____          _
     / ____|        | |
    | |     ___   __| | ___  ___ _____   __
    | |    / _ \ / _  |/ _ \/ __/ _ \ \ / /
    | |___| (_) | (_| |  __/ (_| (_) \ V /
     \_____\___/ \____|\___|\___\___/ \_/
                                    v2.0.22
==> Detecting CI provider
    Travis Detected
==> Preparing upload
==> Processing gcov (disable by -X gcov)
    Executing gcov (['find', '/home/travis/build/Code0x58/python-stripzip', "-not -path './bower_components/**' -not -path './node_modules/**' -not -path './vendor/**'", '-type', 'f', '-name', '*.gcno', '', '-exec', 'gcov', '-pb', '', '{}', '+'])
find: unknown predicate `-not -path './bower_components/**' -not -path './node_modules/**' -not -path './vendor/**''
    Error running `['find', '/home/travis/build/Code0x58/python-stripzip', "-not -path './bower_components/**' -not -path './node_modules/**' -not -path './vendor/**'", '-type', 'f', '-name', '*.gcno', '', '-exec', 'gcov', '-pb', '', '{}', '+']`: Command '['find', '/home/travis/build/Code0x58/python-stripzip', "-not -path './bower_components/**' -not -path './node_modules/**' -not -path './vendor/**'", '-type', 'f', '-name', '*.gcno', '', '-exec', 'gcov', '-pb', '', '{}', '+']' returned non-zero exit status 1.
==> Collecting reports
    Generating coverage xml reports for Python
    + /home/travis/build/Code0x58/python-stripzip/coverage.xml bytes=3249
==> Appending environment variables
    + TRAVIS_OS_NAME
    + TRAVIS_PYTHON_VERSION
==> Uploading
    .url https://codecov.io
    .query commit=38b91d3db01c8298941661b260b3d3b3faf1c756&branch=master&job=335714598&pr=false&service=travis&build=32.5&slug=Code0x58%2Fpython-stripzip&package=py2.0.22
    Pinging Codecov...
    Uploading to S3...
Error: 400 Client Error: Bad Request for url: https://storage.googleapis.com/codecov/v4/raw/2020-05-17/2AA085FFEB8AE9A7F6F779A7CD3EACDA/38b91d3db01c8298941661b260b3d3b3faf1c756/678a8d1c-bd5d-486a-a6ed-786d0c0e97c2.txt?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=GOOG1EQX6OZVJGHKK3633AAFGLBUCOOATRACRQRQF6HMSMLYUP6EAD6XSWAAY%2F20200517%2FUS%2Fs3%2Faws4_request&X-Amz-Date=20200517T124659Z&X-Amz-Expires=10&X-Amz-SignedHeaders=host&X-Amz-Signature=7ca9e41d70298434c624156494848493efc953343a8185e5c1051204f9258239
1 Like

Same issue here for my builds at https://travis-ci.org/github/scour-project/scour

the same here - http://35.192.60.23/PyTorchLightning/pytorch-lightning/2962/1/2
it started about 17h ago and holds… :[
see the commit upload history - https://codecov.io/gh/PyTorchLightning/pytorch-lightning/branch/master/commits

The same issue on AppVeyor https://ci.appveyor.com/project/jazzband/pip-tools/build/job/u76kwcf6sqg8ajdl

Same with Github actions: https://github.com/diofant/diofant/actions/runs/107179945

Hi everyone, thanks for letting us know about this issue. This seems to be happening for many third-party uploaders and we are patching them to resolve the problem. Please let me know which uploader you are using, so we can properly follow up.

Hi everyone, if you are using the python uploader, please upgrade to 2.1.0

If you are using the node uploader, please upgrade to 3.7.0

1 Like

Thanks! I can confirm the latest python codecov is succeeding