Empty coverage reports

Description

Background

  1. We use circle CI and run our python tests inside a docker container. Coverage reports are generated inside this docker container.

  2. As per Testing with Docker, I made sure to mount a filepath where coverage reports will be dumped (here droidlet/config.yml at anurag/yml · facebookresearch/droidlet · GitHub $PWD is being mounted as /shared and all the coverage reports are dumped here like this droidlet/locobot_tests.sh at anurag/yml · facebookresearch/droidlet · GitHub).

Problem
All the coverage files generated in step 2 above are named according to the format “test_*.xml”. However, when I try to upload them using bash <(curl -s https://codecov.io/bash) -f "test_*.xml" -F "locobot" (droidlet/config.yml at anurag/yml · facebookresearch/droidlet · GitHub), it looks like the coverage report uploaded to codecov is empty and I just get a message on codecov.io saying “There was an error processing coverage reports”.

Questions

  1. What is the exact command that the bash uploader runs to generate the coverage xml? How can I look at this generated coverage xml?
  2. I suspected fixing paths could be an issue (as per Path Fixing) since the coverages reports are being generated inside a docker container. But I can’t seem to figure out how to fix this if at all it is a problem (here’s my current solution using fixes in the codecov.yml file that doesn’t work droidlet/codecov.yml at anurag/yml · facebookresearch/droidlet · GitHub)

Repository

The changes mentioned here are in this branch specifically GitHub - facebookresearch/droidlet at anurag/yml

CI/CD or Build URL

Uploaded in the last step here in “Build and run tests”
https://app.circleci.com/pipelines/github/facebookresearch/droidlet/698/workflows/549f4b59-03e1-464a-b87f-2c81110713ec/jobs/1413

Uploader

bash <(curl -s https://codecov.io/bash) -f "test_*.xml" -F "locobot"

Codecov Output

Expected Results

See coverage reports processed on codecov.io

Actual Results

No coverage report.

@anuragprat1k this is really strange. Would you e able to run the uploader in verbose mode with the -v flag? I’d like to see why we didn’t pick up your files.