Coverage not showing up

Description

Coverage is not showing up for files with missing coverage, but percentage results are fine, graphs are rendering ok and project seems to be correctly configured. Here’s the page in question:

Also happens for other files:

When I run coverage html, I do see a correct report. Maybe there’s something wrong with codecov.io itself. I looked at the console:

tests.py:43 GET https://fullstory.com/s/fs.js net::ERR_BLOCKED_BY_CLIENT
(anonymous) @ tests.py:43
(anonymous) @ tests.py:49
tests.py:1 Refused to load the script 'data:application/javascript;base64,KGZ1bmN0aW9uKCkgewoJLy8gaHR0cHM6Ly9kZXZlbG9wZXJzLmdvb2dsZS5jb20vYW5hbHl0aWNzL2Rldmd1aWRlcy9jb2xsZWN0aW9uL2FuYWx5dGljc2pzLwoJdmFyIG5vb3BmbiA9IGZ1bmN0aW9uKCkgewoJCTsKCX07Cgl2YXIgbm9vcG51bGxmbiA9IGZ1bmN0aW9uKCkgewoJCXJldHVybiBudWxsOwoJfTsKCS8vCgl2YXIgVHJhY2tlciA9IGZ1bmN0aW9uKCkgewoJCTsKCX07Cgl2YXIgcCA9IFRyYWNrZXIucHJvdG90eXBlOwoJcC5nZXQgPSBub29wZm47CglwLnNldCA9IG5vb3BmbjsKCXAuc2VuZCA9IG5vb3BmbjsKCS8vCgl2YXIgdyA9IHdpbmRvdywKCQlnYU5hbWUgPSB3Lkdvb2dsZUFuYWx5dGljc09iamVjdCB8fCAn...0gY2F0Y2ggKGV4KSB7CgkJfQoJfTsKCWdhLmNyZWF0ZSA9IGZ1bmN0aW9uKCkgewoJCXJldHVybiBuZXcgVHJhY2tlcigpOwoJfTsKCWdhLmdldEJ5TmFtZSA9IG5vb3BudWxsZm47CglnYS5nZXRBbGwgPSBmdW5jdGlvbigpIHsKCQlyZXR1cm4gW107Cgl9OwoJZ2EucmVtb3ZlID0gbm9vcGZuOwoJd1tnYU5hbWVdID0gZ2E7CgkvLyBodHRwczovL2dpdGh1Yi5jb20vZ29yaGlsbC91QmxvY2svaXNzdWVzLzMwNzUKCXZhciBkbCA9IHcuZGF0YUxheWVyOwoJaWYgKCBkbCBpbnN0YW5jZW9mIE9iamVjdCAmJiBkbC5oaWRlIGluc3RhbmNlb2YgT2JqZWN0ICYmIHR5cGVvZiBkbC5oaWRlLmVuZCA9PT0gJ2Z1bmN0aW9uJyApIHsKCQlkbC5oaWRlLmVuZCgpOwoJfQp9KSgpOw==' because it violates the following Content Security Policy directive: "script-src 'self' 'unsafe-eval' https://www.google-analytics.com https://ajax.googleapis.com *.stripe.com https://fullstory.com https://codecov-cdn.storage.googleapis.com 'sha256-CIs2dFHqtIsuMx4Ifc9FncnEWOoKljuLK8jLxvoaSB8=' 'sha256-HXcLlWJ7mifFtqL6lR9wyiD46Nx2DPSLQAKNuS7hyi4=' 'sha256-EY6rgE4jL342XQYDrJU4NwTe01/LA7aEFt5fqciduPs=' 'sha256-Xka1nGXPZvrRUY1sbksxaAL1yz4UM/V/lqPcy2SuKK0=' 'sha256-rw2f6SLqO1pDmvVyWiJscer3uKHUQkjaKZuMY18BtBo=' 'sha256-AlL/9zTip3pSEmOSNSzKmUV82PbVFX3zYfOBCoQHiJo=' 'sha256-4E22mChcLIDnmzkGL+G7FFdbTRJP9QEhaL5HV87ENwM=' 'sha256-4HRm+SsJXTSA0hcixUhh76R+VEivvdioie3szPSQyNY=' 'sha256-m1VD5+xFa7VZ06/K75lEQ5LcwZz8EdEl65GOq5hvdsM=' 'sha256-JdEps8qsUHCFI2A7eawg6dtGvdB71zOZPGBjtJbmoSk=' 'sha256-VFw4sJIt4Zc0+//eYnksN8Ku9qMhbPpHJEkXMWUiD30=' 'sha256-/dTi/ve7ah34TmEka6qw3wGrA9Hhvu+Fixv0xUB8H6s=' 'sha256-uhsd3LKdZUcgVCm7hgZNXuqVqU+gMa/YBa6Ci3aL9uc=' 'sha256-cn8P5aOZvWmX/d2WCXYlruuqA4Ii27w4JjkYaCnpK4w=' 'sha256-mxROEOYdWYUC+DPd1C0Ym7KSkYn7+Pu4R8BIevjDlZI=' 'sha256-zWB9ScoWsUh4WkHIu4UcUF8EP9gcyiZZ1m9UmxOQWNo=' 'sha256-7XV+fBb7hrbjiohc2WHACla7S4FlVDTXQ9Kt67fGvOg=' 'nonce-BERemGb0xJp12ACIGFP3Nd' 'nonce-BDrc12F0xJp12ACIGFP3Nd' 'sha256-NkrmAUONj58QHqeh6TcllquN7F7zAb7G/sC8Cnebdb0=' 'sha256-SNFCiO5ayrLbpolNCNE7w1BfNHQYRCyVwnL4KfvTPmo=' 'sha256-MN7HRw7yJ5t28MuxkXrv1hu1tIHetOGvCgQUpab74kA='". Note that 'script-src-elem' was not explicitly set, so 'script-src' is used as a fallback.

but I did not have that content-policy error on Firefox nor in private mode so it may be unrelated.

Repository

Steps to Reproduce

  1. Fork my fork
  2. Make sure you have travis-ci.com enabled and authenticated so CI can run
  3. git checkout 82a6245
  4. Push an empty commit to trigger the CI on that specific commit git commit -m "empty commit to trigger CI and code coverage report"--allow-empty

Expected behavior: codecov reports, you go there and you’d see coverage lines

Actual behavior: I don’t see lines covered and lines not covered

Flakiness? I don’t know, haven’t tried again, just posting here as previous repos where I added coverage did work so I’m wondering what’s going on.

Versions

  • Tested with Chrome latest version Version 74.0.3729.169 (Official Build) (64-bit), also happens in private navigation, no ad blocker
  • Tested with Firefox 68.0b8 (64-bit)

Additional Information

You must have an internet connection :scream: