Codecov stuck in "Unable to find report content in the storage archive. "

e.g. in this commit:
https://codecov.io/gh/diofant/diofant/commit/e40cf6ea11c867893ca78d64c24fc22f11d05413

codecov tool reported a successul upload:

 codecov --required --tries 10
  shell: /bin/bash -e {0}
  env:
    TERM: xterm
    pythonLocation: /opt/hostedtoolcache/Python/3.7.9/x64
    LD_LIBRARY_PATH: /opt/hostedtoolcache/Python/3.7.9/x64/lib

      _____          _
     / ____|        | |
    | |     ___   __| | ___  ___ _____   __
    | |    / _ \ / _  |/ _ \/ __/ _ \ \ / /
    | |___| (_) | (_| |  __/ (_| (_) \ V /
     \_____\___/ \____|\___|\___\___/ \_/
                                    v2.1.10

==> Detecting CI provider
    GitHub Actions CI Detected
    Fixing merge commit SHA
==> Preparing upload
==> Processing gcov (disable by -X gcov)
==> Collecting reports
    Generating coverage xml reports for Python
    + /home/runner/work/diofant/diofant/coverage.xml bytes=3462382
==> Uploading
    .url https://codecov.io
    .query commit=e40cf6ea11c867893ca78d64c24fc22f11d05413&branch=nocov-regressions&pr=1060&build_url=http%3A%2F%2Fgithub.com%2Fdiofant%2Fdiofant%2Factions%2Fruns%2F351922270&token=<secret>&service=github-actions&build=351922270&slug=diofant%2Fdiofant&yaml=.codecov.yml&package=py2.1.10
    Gzipping contents..
    Compressed contents to 212196 bytes
    Pinging Codecov...
    Uploading to S3...
    Uploading to S3 took 0:00:00.249216
    https://codecov.io/github/diofant/diofant/commit/e40cf6ea11c867893ca78d64c24fc22f11d05413

See pr: https://github.com/diofant/diofant/pull/1060

1 Like

Also, payload rediliver produces “Unable to find commit in GitHub” entry in the project dashboard.

1 Like

Same problem. Had a repository working perfectly yesterday. Same repo now says “Unable to find commit in GitHub” as well as “Unable to find report content in the storage archive.” when I try to browse the report. Hadn’t made any changes on my end except making a test upload.

EDIT:
Appears to be working again.

1 Like

Apologies all, this seems to be a backup in our queues yesterday. It has since been resolved.

1 Like