Codcov not tracks ignored files in my Ruby project

Please check the troubleshooting guide before creating a ticket.
All fields below are required.

Description

Inside the Rspec, it is set to track track_files 'lib/**/*.rb', but in the report it tracks things outside the lib directory like shown in the following screenshot:

Commit SHAs

f41d2ba234b435c364153b987e7f0ea4acd88746

Repository

CI/CD or Build URL

Uploader

Bash

Codecov Output

  _____          _
 / ____|        | |
| |     ___   __| | ___  ___ _____   __
| |    / _ \ / _\`|/ _ \/ __/ _ \ \ / /
| |___| (_) | (_| |  __/ (_| (_) \ V /
 \_____\___/ \__,_|\___|\___\___/ \_/
                               Ruby-0.2.12
==> GitHub Actions detected
==> Appending file network
==> Gzipping contents
==> Uploading reports
    url:   https://codecov.io
    query: token=secret&flags&package=ruby-0.2.12&service=github-actions&branch=&slug=tianhaoz95%2Ffastlane-plugin-flutter_version&build=416670900&commit=f41d2ba234b435c364153b987e7f0ea4acd88746
->  Pinging Codecov
https://codecov.io/upload/v4?token=secret&flags&package=ruby-0.2.12&service=github-actions&branch=&slug=tianhaoz95%2Ffastlane-plugin-flutter_version&build=416670900&commit=f41d2ba234b435c364153b987e7f0ea4acd88746
->  Uploading to
https://storage.googleapis.com/codecov/v4/raw/2020-12-12/A624B203C56CB512753E3E6A6C5BE91B/f41d2ba234b435c364153b987e7f0ea4acd88746/c2942405-7863-4701-854d-bcb3851041e9.txt?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=GOOG1EQX6OZVJGHKK3633AAFGLBUCOOATRACRQRQF6HMSMLYUP6EAD6XSWAAY%2F20201212%2FUS%2Fs3%2Faws4_request&X-Amz-Date=20201212T013913Z&X-Amz-Expires=10&X-Amz-SignedHeaders=host&X-Amz-Signature=0e07f25165593b4dd57aa85ea6021e82901d303a99f4acd5d5d87b30dac5bf1b
    View reports at https://codecov.io/github/tianhaoz95/fastlane-plugin-flutter_version/commit/f41d2ba234b435c364153b987e7f0ea4acd88746
The following cops were added to RuboCop, but are not configured. Please set Enabled to either `true` or `false` in your `.rubocop.yml` file.

Please also note that can also opt-in to new cops by default by adding this to your config:
  AllCops:
    NewCops: enable
Lint/DuplicateBranch: # (new in 1.3)
  Enabled: true
Lint/DuplicateRegexpCharacterClassElement: # (new in 1.1)
  Enabled: true
Lint/EmptyBlock: # (new in 1.1)
  Enabled: true
Lint/EmptyClass: # (new in 1.3)
  Enabled: true
Lint/NoReturnInBeginEndBlocks: # (new in 1.2)
  Enabled: true
Lint/ToEnumArguments: # (new in 1.1)
  Enabled: true
Lint/UnexpectedBlockArity: # (new in 1.5)
  Enabled: true
Lint/UnmodifiedReduceAccumulator: # (new in 1.1)
  Enabled: true
Style/ArgumentsForwarding: # (new in 1.1)
  Enabled: true
Style/CollectionCompact: # (new in 1.2)
  Enabled: true
Style/DocumentDynamicEvalDefinition: # (new in 1.1)
  Enabled: true
Style/NegatedIfElseCondition: # (new in 1.2)
  Enabled: true
Style/NilLambda: # (new in 1.3)
  Enabled: true
Style/RedundantArgument: # (new in 1.4)
  Enabled: true
Style/SwapValues: # (new in 1.1)
  Enabled: true
For more information: https://docs.rubocop.org/rubocop/versioning.html
Running RuboCop...
Inspecting 8 files
........

8 files inspected, no offenses detected

Expected Results

flutter_version_action_spec.rb should not be tracked.

Actual Results

It is tracked together with the lib directory.

Additional Information

N/A

@tianhaoz95, huh, this looks like an issue on the Simplecov side, as Codecov receives coverage for that file.

However, to unblock you, you can add ignore to a codecov.yml file. Something like

ignore:
  - "spec/"

should work.